No operational issues were reported overnight; CTi and Microsoft will continue to monitor throughout the day to ensure no issues reappear as usage of DDM returns to normal.
A final update will be sent at close of play today 24 June 2025.
Posted Jun 24, 2025 - 10:07 BST
Monitoring
CTi with Microsoft, have resolved the issue that was preventing users from being able to add/modify or delete data within DDM. Users are advised that they may start to use the system once again. Monitoring will continue this evening and an update will sent on Tuesday 24th June.
Posted Jun 23, 2025 - 17:37 BST
Update
CTi are continuing to work with Microsoft to identify a resolution; a further update will be sent by close of play today.
Posted Jun 23, 2025 - 15:11 BST
Update
We are continuing to investigate this issue.
Posted Jun 23, 2025 - 11:22 BST
Investigating
Dear DDM Company Admin,
What is this notification about? This notice is to advise you that CTI are currently investigating an issue that is impacting the DDM Production Market Service.
How does it impact me? Users may experience a Network Exception Error when attempting to perform any actions in DDM. CTI have engaged Microsoft to assist in the investigation and the issue is being actively worked on.
What action must I take? Please cascade this information to the DDM users within your organisation.
Next update CTI are working with Microsoft and further comms will be issued as soon as we have an update regarding this issue.
Support If you require assistance please contact the DDM Service Desk on details below: