DDM Service Notification - Incident

Incident Report for LIMOSS

Monitoring

Dear DDM Company Admin,

What is this notification about?
This notice is to update you on the Microsoft incident which was impacting the DDM Production Market Service.

Progress update
Microsoft advised CTI that a high volume of requests to their UK South Region caused slowness in their Defender service. They have since scaled up their infrastructure to handle the increased traffic, which appears to have mitigated the impact on the DDM application.

What action must I take?
Please cascade this information to the DDM users within your organisation.

Next update
A further update will be issued tomorrow once we have seen a prolonged period of stability on DDM.

Support
If you require assistance please contact the DDM Service Desk on details below:

CTi DDM Service Desk
Phone: +44 800 024 6089
Click here for regional numbers
DDM Service Portal: https://charlestaylor.service-now.com/dasats
Posted Nov 04, 2025 - 16:34 GMT

Investigating

Dear DDM Company Admin,

What is this notification about?
This notice is to advise you that the Microsoft Azure issue previously resolved by Microsoft this morning has unfortunately resurfaced. This is currently impacting the uploading of BDXs and CTI have once again reached out to Microsoft for support.

How does it impact me?
The DDM and Data Extract Production Services are available, however when trying to upload a BDX users may receive a Malware error message.

What action must I take?
Please cascade this information to the DDM and Data Extract users within your organisation.

Next update
A further notification will be sent when an update is received from Microsoft.

Support
If you require assistance please contact the DDM Service Desk on details below:

CTi DDM Service Desk
Phone: +44 800 024 6089
Click here for regional numbers
DDM Service Portal: https://charlestaylor.service-now.com/dasats
Posted Nov 04, 2025 - 14:42 GMT
This incident affects: Delegated Data Manager (DDM).