DDM Service Notification - Performance Issues

Incident Report for LIMOSS

Resolved

Dear DDM Company Admin,

What is this notification about?
This notice is to confirm that CTI have completed the key tasks to resolve the performance issues that were impacting the DDM Production Service.

There are however some on-going activities relating to the archiving of data for non DDM Elective orgs. This will continue as CTI have committed to archive the data across the top 5 tables in DDM. The activities will have no impact on those orgs who currently use the DDM Elective service but should continue to help improve overall performance in DDM.

What action must I take?
Please cascade this information to the DDM and Data Extract users within your organisation.

Support
If you require assistance, please contact the DDM Service Desk on details below:

CTi DDM Service Desk
Phone: +44 800 024 6089
Click here for regional numbers
DDM Service Portal: https://charlestaylor.service-now.com/dasats
Posted Jun 13, 2025 - 15:25 BST

Update

Dear DDM Company Admin,

What is this notification about?
This notice is to update you on the progress of fixing the intermittent performance issues impacting the DDM Production Market Service.

Progress update
Over the last two weeks CTI have undertaken a number of activities to mitigate the on-going performance issues being experienced. These include:

- Increasing the CPU capacity
- Rebuilding indexes for the Bulk Delete process
- Fixing a defect with the Bulk Upload process
- Data Segregation for non-elective DDM contracts

The final fix is due to be implemented on Friday 6th June alongside the BAU Maintenance release. This will involve optimising the logic for the table ‘ValueChangeDataCapture’ for Risk and Premium BDXs and should resolve the remaining issues.

What action must I take?
Please cascade this information to the DDM and Data Extract users within your organisation.

Support
If you require assistance, please contact the DDM Service Desk on details below:

CTi DDM Service Desk
Phone: +44 800 024 6089
Click here for regional numbers
DDM Service Portal: https://charlestaylor.service-now.com/dasats
Posted Jun 05, 2025 - 16:21 BST

Identified

Dear DDM Company Admin,

What is this notification about?
This notice is to update you on the intermittent performance issues impacting the DDM Production Market Service.

Progress update
CTI have identified a number of queries (eg. bulk upload, bulk delete, processing large BDX files) which may trigger increased CPU utilisation on DDM leading to slowness and performance degradation. CTI continue to investigate and are looking at options for optimisation and performance tuning.

What action must I take?
Please cascade this information to the DDM users within your organisation.

Next update
A further update will be provided once CTI are able to implement a fix to improve the DDM performance.

Support
If you require assistance, please contact the DDM Service Desk on details below:

CTi DDM Service Desk
Phone: +44 800 024 6089
Click here for regional numbers
DDM Service Portal: https://charlestaylor.service-now.com/dasats
Posted May 12, 2025 - 12:08 BST

Investigating

Dear DDM Company Admin,

What is this notification about?
This notice is to advise you that CTI are currently investigating slowness and performance issues on the DDM Production Market Service.

How does it impact me?
Users may experience intermittent slowness across DDM, which is not isolated to any specific functionality within the application. The slowness typically lasts for a short period before recovering automatically.

What action must I take?
Please cascade this information to the DDM users within your organisation.

Next update
CTI are actively investigating several scenarios that could be contributing to the performance issues. A further update will be issued once CTI have been able to identify the root cause.

Support
If you require assistance, please contact the DDM Service Desk on details below:

CTi DDM Service Desk
Phone: +44 800 024 6089
Click here for regional numbers
DDM Service Portal: https://charlestaylor.service-now.com/dasats
Posted May 08, 2025 - 14:59 BST
This incident affected: Delegated Data Manager (DDM).