Urgent DDM Service Notification

Incident Report for LIMOSS

Resolved

Dear DDM Company Admin,

What is this notification about?
This notice is to confirm the Microsoft Azure incident which was impacting the DDM Production Market Service has been resolved by Microsoft. CTI are awaiting the formal RCA (root cause analysis) report from Microsoft which is being tracked and managed via a Problem ticket.

What action must I take?
Please cascade this information to the DDM users within your organisation.

Support
If you require assistance, please contact the DDM Service Desk on details below:

CTi DDM Service Desk
Phone: +44 800 024 6089
Click here for regional numbers
DDM Service Portal: https://charlestaylor.service-now.com/dasats
Posted Oct 13, 2025 - 09:54 BST

Investigating

Dear DDM Company Admin,

What is this notification about?
This notice is to advise you that CTI have identified a potential Microsoft Azure issue which is impacting the uploading of BDXs.

How does it impact me?
The DDM and Data Extract Production Services are available, however when trying to upload a BDX users may receive a Malware error message. The issue is currently under investigation by CTI who have raised an urgent ticket with Microsoft.

What action must I take?
Please cascade this information to the DDM and Data Extracts users within your organisation.

Next update
A further notification will be sent when an update is received from Microsoft.

Support
If you require assistance, please contact the DDM Service Desk on details below:

CTi DDM Service Desk
Phone: +44 800 024 6089
Click here for regional numbers
DDM Service Portal: https://charlestaylor.service-now.com/dasats
Posted Oct 10, 2025 - 15:18 BST
This incident affected: Delegated Data Manager (DDM).