Cloudflare Global Outage

Incident Report for LIMOSS

Resolved

Cloudflare have confirmed the issue is resolved. FCP, the LIMOSS Website and Academy are now fully operational.
Posted Nov 18, 2025 - 15:24 GMT

Investigating

Cloudflare is experiencing an ongoing global network outage today (18th November 2025) which has caused widespread disruption, downtime or degraded performance for many customer services.

• Cloudflare has acknowledged the issue
• Partial mitigation's have been applied
• They are still actively investigating the root cause and working on full restoration
Posted Nov 18, 2025 - 14:44 GMT
This incident affected: Faster Claims Payment (FCP), LIMOSS Academy, and LIMOSS Website.