Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 08, 2025 - 13:30 GMT
Scheduled
Dear Market Business Glossary User,
What is this notification about? LIMOSS is pleased to announce that the latest set of MRC Dataset Enhancements has been successfully released to the Market Business Glossary (MBG). This update delivers a fully structured version of the MRC dataset, improving consistency across outputs, enabling more advanced filtering and API-driven consumption.
What action must I take? Please cascade this information to all Market Business Glossary users within your organisation.
Support Should you require assistance or additional information about the MRC content or the MRC API, please contact the LIMOSS Service Desk at servicedesk@limoss.london.
Posted Dec 08, 2025 - 13:19 GMT
This scheduled maintenance affected: Market Business Glossary.